3-Matic-to-Mimics Script Connection Issue

I’ve written a script that creates a spline in 3-Matic by creating the points in 3-Matic, then starting a new Mimics file, transferring the points to the Mimics file, creates a spline in the Mimics file, and transfers the spline from the Mimics file to the original 3-Matic file.

The script has worked in the past, but a certain bug has always afflicted it and the fix I had for the bug doesn’t seem to work anymore.

The bug is that when the script opens 3-Matic, instead of executing the rest of the script, Mimics will try (and fail) to connect to one of the 3-Matic listener. Not only does this bug prevent the script from running, it also makes me forcibly terminate Mimics in order to stop Mimics from trying to connect to the listener, which can be time intensive.

In the past when this bug showed up, I would fix it by turning on 3-Matic’s listener before executing the script. I would then run the script and Mimics would crash as soon as it opened. Then I’d turn off the 3-Matic listener, run the script a second time, and (rather inexplicably) it would run all the way through.

Now my bug fix doesn’t prevent Mimics from trying to connect to the listener and the script can’t run.

Here’s pictures of the code that facilitates the transition from 3-Matic to Mimics:

Here’s a picture of the Mimics log trying to connect to the 3-Matic listener:

Do you have any suggestions on fixes to this bug?

Thank you in advance for your help,

Hi Ian,

Thank you for reaching out to us regarding this issue.
I’m still investigating this issue, but in the meantime, could you try this workaround - specify the port number through command line as below?

Here is an example:
3-matic.exe -activate_listener -listener_port 15005

This command launches a 3-matic application that listens to port 15005.

For more detail, please refer to help in 3-matic’s command line as follow:

Please let me know if this helps!

Kind regards,

Hello Imanina,

Thank you for the fix. It does seem to have worked!

Kind regards,

1 Like

Hi Ian,

Thanks for letting us know :)
Glad to know that it works for you!

Kind regards,