Mimics.file Attribute Error

I’m attempting to import images to a new mimics file similar to the “Automatic import of DICOM images (Mimics 22.0)” post. Up until today, this script worked just fine. Now when I try to execute the script I get an error that doesn’t make any sense:

How could mimics not have the file attribute?

Here’s the code I’m using that’s opening mimics and just now producing the error:
Opens mimics from 3-Matic:

Once in mimics, this line produces an error:

Thank you in advance for your assistance,

Hi Ian,

As I can’t reproduce this error, this is most likely a Mimics bug. Have you tried restarting your pc/laptop?

If the issue still persists, I would suggest you to file this issue via your nearest AE.

Kind regards,

Hi Imanina,

I have restarted the laptop. The issue persisted. Could you clarify what you mean by “AE”?

Thank you,

Hey Ian,

AE is our abbreviation for application engineer, your local technical point of contact thus Maya in your case.

Have a nice weekend!

1 Like